Welcome Guest, Not a member yet? Create Account  




installation problem on physical machine

#1

Hello,

I'm trying to install VyOS on a physical machine with an usb pen drive. When I launch the boot, the system displays :
Loading, please wait ...
No arrays found in config file or autmatically

Boot Failed!
this Debian Live image failed to boot
[...]
live-initranfs will new start a shell. The error message was : Unable to find a memdium containing a live file system
BusyBox v (Debian 1.19.0-1+vyatta+6+hydrogen1) built-in shell (ash)
/bin/sh: can't access tty: job control turned off


I don't understand the problem, if someone can explain me what is wrong and how can I fixe it.

Also I tried to install this iso with a vmware workstation, and it installs correctly.

Best regards,
Damien
Reply

#2

(24/03/2014, 17:51)Damien Wrote: Boot Failed!
this Debian Live image failed to boot
I don't understand the problem, if someone can explain me what is wrong and how can I fixe it.
Also I tried to install this iso with a vmware workstation, and it installs correctly.


This is not your problem.
The usb drivers do not recognise your USB hardware (driver missing)
Hence the booted kernel can not access the rest of the usb flash drive.
This is specifically with newer hardware the case.

Could you try:

A newer (not considered _stable_ !!) version of the vyos ported to debian wheezy iso's:

http://packages.multi.eu/iso/wheezy-transit/

Does that one boot further ?
Has newer kernel with newer drivers
Reply

#3

I tryed with the iso wheezy-transit, when i boot with this one. I have nothing, only : SYSLINUX 3.86 2010-04-01 EBIOS Copyright © 1994-2010 H. Peter Anvin et al
Reply

#4

Finally i boot on the vyos' shell with one of iso file on the url (http://packages.multi.eu/iso/wheezy-transit/).

After i try to install with the command install image, but i have a message :
Warning : GPT (GUID Partition Table) detected on '/dev/sda' ! The utils sfdisk doesn't support GPT. Use GNU Parted.

Also I tryed with the command install system, the problem is the same.

How can I use the GNU parted?
Reply

#5

(25/03/2014, 14:56)Damien Wrote: Finally i boot on the vyos' shell with one of iso file on the url (http://packages.multi.eu/iso/wheezy-transit/).

After i try to install with the command install image, but i have a message :
Warning : GPT (GUID Partition Table) detected on '/dev/sda' ! The utils sfdisk doesn't support GPT. Use GNU Parted.

Also I tryed with the command install system, the problem is the same.

How can I use the GNU parted?

I am sorry you ran into these problems.
VyOS is not (yet) equipped for (U)EFI (successor of good old BIOS)
Go into your "bios" settings and put in it legacy mode
Make sure your hard drive doesn't have (u)efi signature on it

You can do this by typing on the shell when booted from the USB cd image:

sudo cfdisk -z /dev/[your primary harddrive]

This will initialize the drive "blank"

write it to the drive,
reboot again from the usb stock
It should allow you to use msdos formatting now, and will boot
It did on my new dell T20 with efi
Good luck and let us know if it worked
Reply

#6

Ok, thank you very much.
It was a little difficult but my uefi is correctly in legacy mod and i formated my hard drive in msdos, and after i succesfully installed vyos.

I have a question for my culture, why the hard drive must be formatting in msdos for the installation works?
Reply

#7

(26/03/2014, 17:53)Damien Wrote: Ok, thank you very much.
It was a little difficult but my uefi is correctly in legacy mod and i formated my hard drive in msdos, and after i succesfully installed vyos.

I have a question for my culture, why the hard drive must be formatting in msdos for the installation works?

Just the fact that on current vyos, grub 2.0 is used, which is msdos partitioning only.
In future versions of vyos, we will need to change the installer to recognize both msdos and efi systems and when EFI is detected it should install grub-efi.
I will put a request for enhancement in the bugzilla database.

Thank you for the confirmation you got it working!
Reply





Users browsing this thread:
1 Guest(s)