Welcome Guest, Not a member yet? Create Account  




QOS Policy Route bug build 999.201711232137

#1

OK so I have been running the daily builds due to hardware compatibility, but have found a bug with the QOS Policy route behaviors. 

Here are the rules:

set policy route QOS_RULES
set policy route QOS_RULES description "QOS Rules"


set policy route QOS_RULES rule 100 source address 192.168.0.161/32
set policy route QOS_RULES rule 100 set dscp 38

set policy route QOS_RULES rule 131 source address 192.168.0.181/32
set policy route QOS_RULES rule 131 set dscp 26

set policy route QOS_RULES rule 132 source address 192.168.0.182/32
set policy route QOS_RULES rule 132 set dscp 26

set policy route QOS_RULES rule 133 source address 192.168.0.183/32
set policy route QOS_RULES rule 133 set dscp 26

set policy route QOS_RULES rule 134 source address 192.168.0.184/32
set policy route QOS_RULES rule 134 set dscp 26

set policy route QOS_RULES rule 135 source address 192.168.0.185/32
set policy route QOS_RULES rule 135 set dscp 26

set policy route QOS_RULES rule 136 source address 192.168.0.186/32
set policy route QOS_RULES rule 136 set dscp 26

set policy route QOS_RULES rule 137 source address 192.168.0.187/32
set policy route QOS_RULES rule 137 set dscp 26

set policy route QOS_RULES rule 161 source address 192.168.0.191/32
set policy route QOS_RULES rule 161 set dscp 14

set policy route QOS_RULES rule 162 source address 192.168.0.192/32
set policy route QOS_RULES rule 162 set dscp 14

set policy route QOS_RULES rule 171 source address 192.168.0.170/32
set policy route QOS_RULES rule 171 set dscp 10

set policy route QOS_RULES rule 10
set policy route QOS_RULES rule 10 source address 192.168.0.0/24
set policy route QOS_RULES rule 10 set dscp 18

----------------------------------------------
After a few hours look at what happens to rule 99. It looses the IP addresses and starts applying source addr 0.0.0.0
 I believe this happens after hours of heavy traffic through that rule as when I don't have any traffic going through it works fine for days, but last few days I have driven 100's of GB through it. 

if I clear the counter "clear policy route QOS_RULES counters" then it displays correctly, but I am not convinced this is a display bug due to the way the other counters are increments. 


rule  action   proto     packets  bytes
----  ------   -----     -------  -----
10    set      --        321775624961 DSCP
  condition - saddr 0.0.0.0/0 daddr /* set 0x12

99    set      --        321247469777 DSCP
  condition - saddr 0.0.0.0/0 daddr /* set 0x0e

100   set      all       180214   21958430
  condition - saddr 192.168.0.161 daddr 0.0.0.0/0 DSCP set 0x26

131   set      all       0        0
  condition - saddr 192.168.0.181 daddr 0.0.0.0/0 DSCP set 0x1a

132   set      all       38835    6443454
  condition - saddr 192.168.0.182 daddr 0.0.0.0/0 DSCP set 0x1a

133   set      all       2725     789309
  condition - saddr 192.168.0.183 daddr 0.0.0.0/0 DSCP set 0x1a

134   set      all       21802    2819399
  condition - saddr 192.168.0.184 daddr 0.0.0.0/0 DSCP set 0x1a

135   set      all       0        0
  condition - saddr 192.168.0.185 daddr 0.0.0.0/0 DSCP set 0x1a

136   set      all       14088    3164795
  condition - saddr 192.168.0.186 daddr 0.0.0.0/0 DSCP set 0x1a

137   set      all       84197    12000237
  condition - saddr 192.168.0.187 daddr 0.0.0.0/0 DSCP set 0x1a

161   set      --        321775928026 DSCP
  condition - saddr 0.0.0.0/0 daddr /* set 0x0e

162   set      all       31414    2255390
  condition - saddr 192.168.0.192 daddr 0.0.0.0/0 DSCP set 0x0e

171   set      all       67533    6340857
  condition - saddr 192.168.0.170 daddr 0.0.0.0/0 DSCP set 0x0a

10000 drop     --        321776100691 RETURN
  condition - saddr 0.0.0.0/0 daddr /*

I will post this and my NTP to the bugzilla place in a few days.
Reply





Users browsing this thread:
1 Guest(s)