Welcome Guest, Not a member yet? Create Account  




update driver sfc (solarflare ethernet controller)

#1

Hello guys!

I need a light, if anyone can help me, it will be very helpful.

I need to install 'linux-header', is there any repository that I can download?


Code:
Uname -r
3.13.11-1-amd64-vyos


Code:
Vyos: 1.1.7


The big question is that I need to update the "SFC" driver for my SolarFlare network card to work. I did not find anything about it in the community.


Code:
Model: Solarflare Flareon Ultra 8000 Series 10G Adapter


The sfc that comes installed is '3.13.11-1' and needs to update to '4.10.6.1002'

How I am doing:


Code:
Dpkg -i sfc-dkms_4.10.6.1002-1_all.deb
Selecting previously deselected package sfc-dkms.
(Reading database ... 39813 files and directories currently installed.)
Unpacking sfc-dkms (from sfc-dkms_4.10.6.1002-1_all.deb) ...
Setting up sfc-dkms (4.10.6.1002-1) ...

Loading tarball for module: sfc / version: 4.10.6.1002

Loading /usr/src/sfc-4.10.6.1002 ...
Creating /var/lib/dkms/sfc/4.10.6.1002/source symlink ...

DKMS: ldtarball Completed.

Module build for the currently running kernel was skipped since the
Kernel source for this kernel does not seem to be installed.


I can get information in "lspci" but nothing related to interfaces, so the need to upgrade the driver ....


Code:
0c: 00.0 Ethernet controller: Solarflare Communications Device 0a03 (rev 02)
0c: 00.1 Ethernet controller: Solarflare Communications Device 0a03 (rev 02)




Any suggestions are welcome!


Thanks!
Reply

#2

Hello,
if you trying to do that for 1.1.x i have bad news for you, it likely will not work (for several reasons)
Give a try 1.2.x series from here
http://dev.packages.vyos.net/iso/current/amd64/

For 1.2.x it will be possible to build fresh drivers (much newer kernel)
============
Open source routing platform for everyone!
Donate to VyOS project!

Looking for professional services?
Get them here!
Reply

#3

(05/08/2017, 02:26)syncer Wrote: Hello,
if you trying to do that for 1.1.x i have bad news for you, it likely will not work (for several reasons)
Give a try 1.2.x series from here
http://dev.packages.vyos.net/iso/current/amd64/

For 1.2.x it will be possible to build fresh drivers (much newer kernel)

Interesting, I'll try to do that and post an answer in the next few days.

... is there a changelog of these versions of current? I'm not finding ...

Thank you!
Reply

#4

I have not yet had success with the driver, if anyone has any ideas.


Quote:root@vyos:~# uname -a
Linux vyos 4.4.47-amd64-vyos #1 SMP Sun Jul 23 11:41:18 EDT 2017 x86_64 GNU/Linux

Quote:root@vyos:~# cat /etc/debian_version 
8.9

Quote:root@vyos:~# dpkg -i sfc-dkms_4.10.6.1002-1_all.deb 

(Reading database ... 88173 files and directories currently installed.)
Preparing to unpack sfc-dkms_4.10.6.1002-1_all.deb ...

Uninstall of sfc module (version 4.10.6.1002) beginning:

------------------------------
Deleting module version: 4.10.6.1002
completely from the DKMS tree.
------------------------------
Done.
Unpacking sfc-dkms (4.10.6.1002-1) over (4.10.6.1002-1) ...
Setting up sfc-dkms (4.10.6.1002-1) ...

Loading tarball for sfc-4.10.6.1002

DKMS: ldtarball completed.

Creating symlink /var/lib/dkms/sfc/4.10.6.1002/source ->
                /usr/src/sfc-4.10.6.1002

DKMS: add completed.

Module build for the currently running kernel was skipped since the
kernel source for this kernel does not seem to be installed.

Quote:root@vyos:~# dpkg-query -l
ii  linux-doc-4.4.47-amd64-vyos      4.4.47-1+vyos1+current1          all          Linux kernel specific documentation for version 4.4.47-amd64-vyos
ii  linux-headers-4.4.47-amd64-vyos  4.4.47-1+vyos1+current1          amd64        Header files related to Linux kernel, specifically,
ii  linux-image-4.4.47-amd64-vyos    4.4.47-1+vyos1+current1          amd64        Linux kernel binary image for version 4.4.47-amd64-vyos
ii  linux-manual-4.4.47-amd64-vyos   4.4.47-1+vyos1+current1          all          Linux kernel section 9 manual pages for version 4.4.47-amd64-vyos
ii  linux-source-4.4.47-amd64-vyos   4.4.47-1+vyos1+current1          all          Linux kernel source for version 4.4.47-amd64-vyos
Reply

#5

Funny.. I installed the necessary packages and he still says I do not have the necessary packages.
Reply





Users browsing this thread:
1 Guest(s)