Welcome Guest, Not a member yet? Create Account  




Question NATの設定について

#1

vyos経由でインターネットに繋ごうとしているのですが、PCからインターネット側(8.8.8.8)へのPing応答がありませんでした。
vyosは8.8.8.8へのpingは正常でした。

vyosの設定をどのようにすればPCからインターネットへつなげるようにできるのでしょうか。


構成のイメージ画像を添付しました。

nat destinationあたりの設定がおかしいのかもしれませんが、どうすれば良いのかわかりません。

よろしくお願い致します。


Code:
set interfaces ethernet eth0 address 'dhcp'
set interfaces ethernet eth0 duplex 'auto'
set interfaces ethernet eth0 smp-affinity 'auto'
set interfaces ethernet eth0 speed 'auto'
set interfaces ethernet eth1 address '10.0.2.7/24'
set interfaces ethernet eth1 duplex 'auto'
set interfaces ethernet eth1 smp-affinity 'auto'
set interfaces ethernet eth1 speed 'auto'
set interfaces loopback 'lo'
set nat destination rule 10 destination address '10.0.2.5'
set nat destination rule 10 inbound-interface 'eth0'
set nat destination rule 10 source address '0.0.0.0/0'
set nat destination rule 10 translation address '10.0.2.7'
set nat source rule 10 outbound-interface 'eth0'
set nat source rule 10 source address '10.0.2.0/24'
set nat source rule 10 translation address 'masquerade'
set protocols static route 0.0.0.0/0 next-hop 'y.y.y.y'
set service ssh 'disable-password-authentication'
set service ssh port '22'
set system config-management commit-revisions '100'
set system console device ttyS0 speed '9600'
set system host-name 'vyos'
set system name-server '157.7.180.133'
set system name-server '163.44.76.148'
set system ntp server '0.pool.ntp.org'
set system ntp server '1.pool.ntp.org'
set system ntp server '2.pool.ntp.org'
set system syslog global facility all level 'notice'
set system syslog global facility protocols level 'debug'
set system time-zone 'Asia/Tokyo'


Attached Files Thumbnail(s)
   
Reply

#2

使っているクラウドサービスの仕様で、提供されているAPIでファイアーウォールの設定を変更する必要があったようです。

現在は、PCからインターネットへの通信ができるようになりました。
Reply





Users browsing this thread:
1 Guest(s)