Welcome Guest, Not a member yet? Create Account  




Install on ALIX APU2c2

#1

Hello guys,

Anyone tried the vyos on Alix APU2c2?

I have no luck, tried to boot with the live USB, then tried to install the OS on USB or SD-card, no luck it hangs after boot:

Code:
Booting from Hard Disk...
Booting from 0000:7c00
GRUB loadingWARNING - Timeout at sdcard_waitw:162!
Read Error
Reply

#2

Forgot to tell you that the pfSense 64bit works fine on it and installed without any issues. Also tried openwrt.

What could be the problem I dont understand
Reply

#3
(This post was last modified: 05/12/2016, 00:41 by blacktoli.)

Tried the nightly current version and the live-USB boot works fine. However, it does not boot after installation on SSD or SD card, same story.

Code:
.linux /live/vmlinuz boot=live components hostname=vyos username=live nopersistence noautologin nonetworking union=overlay initrd=/live/initrd.img console=ttyS0,1

                Press ENTER to boot or TAB to edit a menu entry

Loading /live/vmlinuz... ok
Loading /live/initrd.img...ok
Probing EDD (edd=off to disable)... ok

[    0.000000] Initializing cgroup subsys cpuset
[    0.000000] Initializing cgroup subsys cpu
[    0.000000] Linux version 4.4.15-amd64-vyos (khagen@jessie64devel) (gcc version 4.9.2 (Debian 4.9.2-10) ) #1 SMP Fri Sep 2 08:29:27 CEST 2016
[    0.000000] Command line: BOOT_IMAGE=/live/vmlinuz boot=live components hostname=vyos username=live nopersistence noautologin nonetworking union=overlay initrd=/ console=ttyS0,115200n8
[    0.000000] x86/fpu: xstate_offset[2]:  576, xstate_sizes[2]:  256
[    0.000000] x86/fpu: Supporting XSAVE feature 0x01: 'x87 floating point registers'
[    0.000000] x86/fpu: Supporting XSAVE feature 0x02: 'SSE registers'
[    0.000000] x86/fpu: Supporting XSAVE feature 0x04: 'AVX registers'
[    0.000000] x86/fpu: Enabled xstate features 0x7, context size is 832 bytes, using 'standard' format.
[    0.000000] x86/fpu: Using 'eager' FPU context switches.
[    0.000000] e820: BIOS-provided physical RAM map:
The version runs fine from usb is vyos-999.201612010232-amd64.iso 
Any solutions?

Thanks
Reply

#4

I have a write-up of the installation I just did (using VirtualBox on Linux to write to the raw CF card) of VyOS 1.1.7 if it's of use to anyone who finds this thread: http://blog.jasonantman.com/2017/03/vyos...-computer/
Reply





Users browsing this thread:
1 Guest(s)